PHP 8.x verursacht noch Fehler

Bis zur Version 23.1 von tikiwiki gibt es in den Verschiedenen Modulen noch Fehler. Ursache ist einen geänderten Umgang bei Zusammensetzen von Werten. So ist z.B. im Kalender (tiki-calendar.php) ein Fataler Fehler. Im Errorlog findet ihr dann den Eintrag:

PHP Fatal error:  Uncaught TypeError: Unsupported operand types: string + int in tiki-calendar.php:284

Mit PHP 7.4 gibt es das Problem nicht. Hoffen wir mal, dass in der nächsten Version, die für Februar 2022 geplant ist, die nötigen Anpassungen gemacht sind.


Permalink: https://wilde.website/blogpost5-PHP-8-x-verursacht-noch-Fehler